Запуск OpenBSD 4.6 на Lenovo ThinkPad SL500

Доброго времени суток, форумчане!

Столкнулся с проблемой запуска OpenBSD 4.6 на ноутбуке Lenovo ThinkPad SL500.
Установка проходит без каких-либо ошибок, если не считать, что при попытке настроить беспроводную сеть выдаётся сообщение:

iwn0: error, 2, could not read firmware iwn-5000
iwn0: could not read firmware
.

Как это можно побороть нашёл в одном из списков рассылки.

Но при первом запуске OpenBSD после вывода информации о процессоре появляется сообщение kernel panic.

Trace и ps ddb выдают следующее:

ddb>trace
Debugger(d0821df8,d2ab29d0,d09e96e8,d2ab75c4,8) at Debugger+0x4
panic(d0812d2c,d081336b,fb3,0,d2ab4804) at panic+0x55
_aml_die(d081336b, fb3, d0813428, 0) at _aml_die+0x46
aml_xparse(d2ab5c84,54,d0813318,d2ab2884,d0) at aml_xparse=0xfae
aml_xeval(d2ab5784, d2ab2884,54,0,0) at aml_xeval+0x154
aml_xparse(d2ab5784,54,d0813318,d2ab2984,d09e9a24) at am;_xparse+0x4f9
aml_xeval(0,d2ab2984,74,1,d09e99f0,d0813dc7,d09e98b8,d061431e) at aml_xeval+0x154
aml_evalnode(d2a55c00,d2ab29c4,1,d09ee99f0,d09e98e0) at aml_evalnode+0x57
acpicpu_set_pdc(d295b400,0,10,0,d0846d44) at acpicpu_set_pdc+0x70
acpicpu_attach(d2a55c00,d295b400,d09e9b10,d2a55c00,0) at acpicpu_attach+0x8a
config_attach(d2a55c00,d081c19c,d09e9b10,d06c4690,d08127a8) at config_attach+0xfd
acpi_add_device(d2a578c4,d2a55c00,d09e9b88,d06c795b) at acpi_add_device+0X6a
aml_walknodes(d2a578c4,0,d06c52f0,d2a55c00,0) at aml_walknodes+0x5d
aml_walknodes(d2a57b84,0,d06c52f0,d2a55c00,d2a57e04) at aml_walknodes+0x2f
aml_walknodes(d0941be0,0,d06c52f0,d2a55c00,d0941be0,d081262d,d06c5fa8,d2a55c00) at walknodes+0x2f
acpi_attach(d2a57d80,d2a55c00,d09e9d40,d2a57f80,d0821df8) at acpi_attach+0x451
config_attach(d2a57f80,d081c0e8,d09e9d40,d063b090) at config_attach+0xfd
biosattach(d2a57fc0,d2a57f80,d09e9e70,d2a57fc0,d0202dd5) at biosattach+0x3ce
config_attach(d2a57fc0,d081b098,d09e9e70,d04d3d9c,d073b220) at config_attach+0xfd
mainbus_attach(d2a57fc0,0,ddf5d000,d09e8334) at mainbus_attach+0x3d
config_attach(0,d08186b0,0,0,0) at config_attach+0xfd
config_rootfound(d0739b620,0,d09e9f38,d04a30ba) at config_rootfound+0x27
cpu_configure(d09408e0,1,20,2) at cpu_configure+0x29
main(0,0,0,0,0) at main+0x399


ddb>ps
PID PPID PGRP UID S FLAGS WAIT COMMAND
* 0 -1 0 0 7 0X80200 swapper


ddb>

Возможно ли разрешить возникшую проблему при запуске? И что является причиной возникновения kernel panic?
На зарубежном форуме в топике с проблемой kernel panic при первом запуске порекомендовали сразу или сменить ноутбук, или поставить ОС из другого семейства *BSD.
Другие версии OpenBSD пока устанавливать не пробовал.

Аватар пользователя BABUT

попробовать

попробовать без acpi?

Аватар пользователя reeve

попробовать

попробовать без acpi?

BABUT, спасибо за совет!
Зашёл в User Kernel Config, отключил ACPI и система загрузилась.

boot>boot -c

UKC>disable acpi
466 acpi0 disabled

UKC>

Осталось только разобраться, как сохранить эту опцию, чтобы не заходить при каждой загрузке OpenBSD в UKC.
Ушёл штудировать маны.

Аватар пользователя SinteZ

А насколько это

А насколько это правильно - работа современного компьютера без ACPI ?
Все ли компоненты в нём будут функциклировать?
Хотелось бы узнать, удалось ли настроить беспроводную связь на iwn-5000 ?

Аватар пользователя test00

А насколько


А насколько это правильно - работа современного компьютера без ACPI ?

Вполне.

Все ли компоненты в нём будут функциклировать?

Все, кроме управления питанием, суспендом, хибернейтом и т.д. Так же не будет датчиков температуры и т.п.

Аватар пользователя ENcrypted

Вот интересно

Вот интересно что за трэд ты нарыл, который тебя заставил поставить snapshot со сломанным AML-парсером.